Package name - how do you set a custom package name?

Can anyone help me fix this error while build it says:

Exception in thread Thread-2 java.lang.UnsatisfiedLinkError: Cant load library: /usr/lib/jvm/java-11-openjdk-

please help me fix it

have you install java and set up JAVA_HOME?
Follow the README .txt instruction.

Thank you so much for helping this beginner.

From the old AI2 forum:

1 Like
1 Like

@Anke i am so happy that my app is exporting without watermark app inventor offline is amazing :slight_smile:

Did that solve your problem with the packageName?
If so, tell the others what packageName it is and what email you used with AI2Offline.

So you installed openjdk 8 under fedora to make it work and switched to that version?

1 Like

Yes it solved all of my problems today i am ultra happy that is something my own self hosted.

Yes this docs: Installing Java :: Fedora Docs and this command : sudo alternatives --set java /usr/lib/jvm/java-1.8.0-openjdk-

1 Like

Another error I got while exporting aab help me fix it please.

Does apk compiles fine or you do you get same error as aab ?

I can build apk and aab with the offline version. Could you build your project with the online version of App Inventor or is this your transfered Kodular project. If so you should open another topic.

@dora_paz @Peter I was mising this library

sudo dnf install java-1.8.0-openjdk-devel.x86_64

I use linux but I am still noob I don't know how to get my query resolved by searching yourself. I always enter search query that isn't good I will have to learn how to search properly.

Like i said, your question about being not able to compile isn't related to this topic that is about using a custom packagename. That's why you have to answer my question if you are able to compile with the online version or not.


Yes I am able to

I was able to export apk but aab was returning errors and after installing the above library the aab can also be exported easily. Thank You for your time and support.

Ai2offline Now, package name custom:
build apk:

Dark Mode:

And your question is?

Use Ethernet network, how make not show this splash ? What modifed ?