New app icon restrictions at build time?

A few new build errors have popped up on the board for icon types recently, for apps that previously built.

Is this an iOS thing?

It may be a possible regression. We are investigating.

We've identified the root cause of the issue and are working on a fix.


It should be fixed by now.

I'm still getting the error...

[LoadComponentInfo] Task succeeded in 0.018 seconds
[PrepareAppIcon] Starting Task
[PrepareAppIcon] INFO: Creating mipmap dirs...
[PrepareAppIcon] INFO: Generating icons...
[PrepareAppIcon] Task errored

Is the true fix to change jpg to png? I understand that this is easy to do and not a big deal for a (small) icon, but this is a workaround and not a fix of the root cause. If a true fix is coming soon, I'd rather wait than risk introducing some other variable by a change in my project, even if a "trivial" change theoretically.

<<yes, i saw jpg to png issue, but the lead software engineer (ewpatton) said "We've identified the root cause of the issue and are working on a fix," and I don't see his response that the "fix" is to change to png. I'd rather not make any changes if the true fix -- to handle jpg's as before -- is still in the works>>

The fix has been deployed. If you are still having problems please send us a copy of your project so that we can take a look.

I had a 593x381 w x h jpg that worked for years. I just changed it to a png, and that works. The jpg still doesn't work.

It's true that I violate the icon restriction -- "The image used for your App's display icon should be a square png or jpeg image with dimensions up to 1024x1024 pixels. Larger images may cause compiling or installing the app to fail. The build server will generate images of standard dimensions for Android devices." -- but it says the server will generate a correct image.

It works, so it's fine by me, but it's not working the way it was yesterday, so there may still be some bug....thanks

Which server are you using to build?

don't see where to find that. I've looked on the page and done a quick google search

Either or

ai2 -- thought you meant like an ip address

FYI: same app i am bulding as it it for last few months without issue, tried to build as apk today and had the new issue ! , rebuilt all jpg as png >> went well ! , so not fixed yet from your side (i tried both servers.. same issue) once jpg >> png >> done,
than you

Building OK here with a 512x512 jpg file.

This has been fixed, therefore


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.