MIT App Inventor Issue (using Companion)

I am also experiencing stalls at 20% from my Brave (Chrome) web browser sessions,
against the Companion app running on MemuPlay emulator.

I just posted we rendezvous server connection dump on a Powere Users thread for previous problems like this.

Hopefully @jis will notice.

I tried vanilla Chrome for my AI2 session, both with and without legacy connection options on the emulated MemuPlay Companion.

Legacy connection entry of the 6 letter code cleared the AI2 connect with companion pop up but did not result in a progress popup. It was followed a few seconds later by a network error connection failure popup from AI2.

WebRTC connection stalled at 20%, same as Brave.

Stop in 20 Establishing ...

Chrome + Kodular COMPANION in Kodular.
Brave + Kodular COMPANION in Kodular.

It works...

Chrome + Legacy MIT COMPANION
FireFox + Kodular COMPANION in Kodular.

1 Like

That's right, but I'm getting an error with that:

11 hours ago it worked by checking "Use Legacy Connection", now it does not work either.

Chrome Version 89.0.4389.82 (Official Build) (64-bit)
When the "Use legacy connection" is selected, it goes beyond "20 Establishing secure connection in Chrome" but gets stuck at "sending assets..." at 50%.

Same thing happens in MS EDGE.
Firefox works OK either way.

I was able to connect to the Companion on MemuPlay from Firefox, without aistarter.

This had worked from Brave (Chrome) until a couple of days ago.

Chrome 89 introduced an incompatibility with our implementation. I have deployed a mitigation and Chrome 89 (and derivatives) should now work.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.