I am trying to use the web browser, however it doesn't open any websites on my chromebook

i use google play store

My app is :
1 button
1 web viewer

I have the web viewer set to go to the url google.com
When button click do call webviewer1 .GoToURL url: google.com
However when i open the app it doesn't go to google it just gives me a blank space where the webviewer is supposed to be and it shows button

And show your relevant blocks

Screenshot 2023-11-25 9.53.59 AM

the Webviewer requires you to provide either an http:// or https:// at the beginning of the url

1 Like

oh okay ill try it right now

wow it worked so weird cus before the chromebook update I didn't have to put https:// and it worked fine. Thank you for helping and being so quick to reply lol.

okay now it pulls up websites, however when i go to the websites they don't load and i get a runtime error.

It would really help if you provided a screenshot of your updated relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select "Download Blocks as Image". You might want to use an image editor to crop etc. if required. Then post it here in the community.


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

breh they the same blocks

my app hasnt made it past 3 blocks :skull:

in your last screenshot you forgot the https://
what do you have now? do you want us to guess or are you providing an updated screenshot?


1 Like


1 Like

I do not have a Chromebook, the blocks look fine though...
so if I understand you correctly, you uploaded a test app into Google Play and installed it from there
then first you said

but then

what exactly means "it pulls up websites"?


generally for runtime errors we have the possibility to use logcat to find out what is going on...
however I do not know how to set this up on a Chromebook? this might help:

generally see here


1 Like

is this where that link is supposed to take me? I don't see any information here

oh also i am trying to make an app for me and my friends but not upload to google play. by pulls up websites i mean when i go to a website such as instagram.com it just stays on the first loading screen and gives me a runtime error.

yes... well, it looks like in your Chromebook some information is missing... probably a general problem on your side?
that page looks like this normally

taken from there

If you can get it to work, I believe this is the simplest way: https://www.howtogeek.com/358285/how-to-use-adb-and-fastboot-on-a-chromebook/


I will take my chromebook somewhere and try to see if my chromebook has problems, because sometimes when I go to websites it says it is not supported on a mobile device. Thanks for the help, (the adb thing doesn't work with my chromebook) :slight_smile:

I have just sideloaded a simple app to my chromebook - Acer 715
(I also tested with companion app on the chromebook)

Loads any site I have tried without issue


testcb.aia (2.0 KB)

oh thank you I will try this.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.