FirebaseDB Authentication problem

Initially, I got help from FirebaseDB secured connection?.
But when I implement I got an error message: Error from Companion: For a custom firebase host you must first set your authentication server before using authentication features!
Please help me to resolve it.

Have you enabled the particular login type on the Firebase console?

In the setting I see google-services.json file. Are you tell about this? Where it will be added?
Yes I enabled the Email/password login type on the firebase console.


This is for using the Kodular built in Firebase components ?

1 Like

Please show your relevant blocks, it would really help others to understand what you are trying to do, and therefore how they may be able to help.

In the blocks.png file in the clock1 block, I use the fibebasedb.storevalue

In the blocks(1).png file I use the Firebase Authentication aix library and enabled sign-in facility with email id and password.

Please check my authentication.

Why oh why are you doing this ?

Remove the evaluate but ignore result block and the do result block. (and the FirebaseAuth1 component block)

You will also need to use the [PAID] extension by Carlos Pedroza in order to deploy the user token

Otherwise, if using App Inventor, see here for using the Firebase REST api with secure rules

I connect the addon extension and get the error message:

I will share my block code please help me to identify the mistake.

First, you will need to check with the extension developer if the addon provides support for Firebase Storage authentication