Error in Post request

"Looks" OK.

Try passing that json string as a text:


1 Like

I tried , But it's not working.

You should run the Do It on the call block, not the Text block.

That will not return an output in a comments box, it will just run the blocks

1 Like

OK ,
But how to avoid this error?

Are you sure your device eui is correct? The chirpstack documentation is somewhat terse but it doesn't show the use of the xx:xx:xx:xx:xx:xx format, just xxxxxxxxxxxxx

1 Like

Device EUI is correct. 00:80:00:00:04:01:4C:E9

You could try removing all the : ?

1 Like

Same error existed after removing : .

Last thing I can think of...replace the setHeaders with this (adding your API Token):

also, are you sure it is an https:// request ? Have you tried http:// ?

I tried, also change https to http, but no change from previous condition.

Its https:// itself. We have enabled TLS in the server. The downlink post request is also working when we tried from postman - this is the command

curl -X POST --header 'Content-Type: application/json' --header 'Accept: application/json' --header 'Grpc-Metadata-Authorization: Bearer eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJhcGlfa2V5X2lkIjoiMjdiZjkyODAtNjVkOC00OWJkLTk0ZGUtNmFlZmUwMTAyYzk4IiwiYXVkIjoiYXMiLCJpc3MiOiJhcyIsIm5iZiI6MTYzMjU4NDAwNiwic3ViIjoiYXBpX2tleSJ9.xpFZKpJ1KyYDyLLKaIkMUUwpAXpBmct8P4_ozFOWYA4' -d '{ \
"deviceQueueItem": { \
"confirmed": false, \
"data": "AQID", \
"fPort": 10 \
} \
}' ''

See here, you could try this way

Worth just checking the response code and type coming back from the server ?


Yes. response code is needed.

What is the responseCode and responseType then ?

do you still get Error 1117?

just posting your blocks does not help very much to see the values for responseCode and responseContent...
what about displaying them in a label and show us the values?


1 Like