Compile Error after new keystore file

Hi All

  1. I have an old app (2017). In those days, to get it into the app store, I went through App2Market, and used a keystore file that was generated there (with a .ks extension).
  2. So, to create a new app release (to conform to sdk 29), I loaded the .aia file in AI, and it compiles perfectly.
  3. When I tried to upload into the Google Play store, I received a certificate error.
  4. I checked on the lists here, and saw that I needed to use that old .ks file
  5. I tried to use that .ks file, but AI would not let me. So, I changed the extension to .keystore, and it seemed to pull it in ok.
  6. Now, however, when I compile, I receive a compiling error (See image).
  7. I have checked my variables in that screen and can't see anything wrong. Besides, the only change I made was the new keystore file, so it is unlikely to be an error in one of my variables.

Any suggestions appreciated.

CompileErrorOnly .


I went to the offending screen and deleted all the components and all the blocks, and compiled again.

This time, I received this error:


Watch this video (from min 1:08):

Thanks, but I'm afraid the video does not help me. Without any kind of narration, I'm simply watching a mouse moving across a screen, sometimes in circles, sometimes clicking, pop-ups and dialog boxes appearing and disappearing and then it ends, and I'm none the wiser :-(.

If you know of something that gives step-by-step instructions, that would help.


Everything has been explained step by step. Also in the description. Maybe you have to watch it several times and press pause. So far everyone has understood.

Most of the time, people want a video tutorial to make it easier to understand. Then you do one thing (which is a lot of work) and then again that is not enough. :upside_down_face: