Can a procedure's contents be viewed?

can a procedure's contents be viewed?

have searched quite a bit but cannot find anything on how to view the steps incorporated into a procedure, or even mentioning that they are not viewable. Double clicking, right clicking, no. Is it a secret what someone's procedure consisrs of? Or I'm missing.....? thanks

What do you mean by if it is visible? A procedure is something you can do within your application, usually to include instructions that will be executed multiple times in the flow to avoid repeating code. The content of the procedure is as visible as any other block in the project.

Maybe you are talking about extension?

(Canned Reply: ABG- Export & Upload .aia)
Export your .aia file and upload it here.


.Tell us which procedure you would like to look inside.

call chrome in ChromeTest.aia

I want to use this in my app, and I can't even get this ChromeTest to call chrome

Maybe if you upload ChromeTest.aia we could look inside it?

Where did you get it?

(moved to new topic)

What is the problem? there is a procedure callChrome, where you can see its content:

If you want to open the .aia file, you have to pull it in with a Project->Import from the ai2 web site.

okay thanks. As I suspected, I was missing something obvious: I didn't realize that that was the definition of the procedure. (For whatever reason, the call ActivityStarter1 at the THEN wasn't firing, so I just pasted a copy outside the IF.) But I was hoping that this would open an instance of Chrome in my app. Instead, it opens a tab in Chrome external to my app.

I've used Webviewer without problems, but for for some reason it's misinterpreting some html that works well otherwise. I tried CustomWebView, and that fixed one problem but not a second, which remains. I'd rather not change the html to accommodate CustomWebView.

It is possible to open a Chrome instance within an appinventor app? (I'm guessing no.) Is there another browser available that opens within an app? thanks

What is the issue with the html in webviewer?

One issue is it brings up particular page at a high zoom (or something else that causes it to appear that way), while Chrome desktop and Firefox render it fine. I tried some small code additions that had no effect, but decided to test with CustomWebView, which rendered it a normal scale but doesn't display a clickable image properly. Webviewer also doesn't render clickable images properly -- at least my 2 examples. If you or someone knows of a setup within CustomWebViewer that solves this clickable image issue, I'll go with that

Clickable image? Does what?

cracked thumnbnail with the text embedded in <form action="https://YYY**

cracied thumbnail
the image and clickableness are fine, but not in Webviewer and CustomWeb

Can you provide a repeatable example of the html, for testing ?

problem appears to be that CustomWeb wasn't fetching image.png url at http. Changed to https and appears to work. I'm guessing that webviewer has the same issue? Seems to be a bug? I would think it would have turned up earlier. thanks