Button misbehaving

Button misbehaving
Good morning everyone and thank you again for your time and advice.
I replaced an exit app button by deleting it with an open settings button.
As you can see from the images.
Even though the blocks are error-free, rather than displaying the virtual "Settings" tab, the App closes.
I replaced the Button component with a new one, also replacing the exit block and opening block, but to no avail.
What happen?

This behavior started after adding audio on the buttons.

Thinking that they were creating the problem, I deleted them and even in that case the behavior is absurd, the App is closed, instead of opening settings.

I would add that I must congratulate you on the new Appinventor interface.
The addition of new features in the properties is truly remarkable and very useful.


which Android version are you using for your tests?
probably a missing permission?
to find out why the app closes, use logcat


The android version is 10. Xiaomi "Redmi note 7".
But it can't depend on this because it worked for months before.
The only detail I can remember is that while I was downloading the .APK, twice the page gave me an error for a page number that I don't remember with several explanations that I had already posted months ago, for the reason that there were too many files and mega of the project, I solved it by switching to appinventor which supports more than ten mega.
Now my project maxes out at 18 KB.

As far as looking at your instructions on adb etc.. too difficult for me.

As I specified, I have done dozens of tests with that button and the same blocks and it has always worked well. I did the task of opening the settings, all of a sudden it no longer worked when I closed the app when pressed.

I downloaded adb r and installed it I think now I'll try. to make the .Apk

Nothing to do doesn't work.
I'll try to retrace my steps and double-check all the code. one step at a time, it will be an undertaking.

While I downloaded ADB, the other download doesn't work

As you can see I followed the instructions even though, in my case I think they are not suitable.
However it gives me an error command not recognized, I ran it as administrator

sorry I wasn't in the directory it works

He's stuck here.

Does this crash ?

buttonBehave.aia (21.4 KB)

It does not work. I think I've discovered what it's all about.
It must be my phone that has some problem, because before it worked on both Android 10 and Android 6.
Now it works on Android 6 but not on Android 10. I try to reset the phone, surely with all these tests and turning it on and off it must have created some problem. Then I'll be able to tell you something more concrete.
As I wrote, your example also doesn't work while on Android 6 it works perfectly.

Sorry, I don't understand anything about programming, but explain to me why it should have worked with an extra component and an .mp3 file.
Was it used to carry out a test of your own design or was it just to see if I really understood something or not of what you sent me.

Here in Italy one would say it seems senseless to me, but I don't dare say it to you, because you must have had your reasons for posting these blocks which seem absurd to me.
If you explain it to me I'll understand something too.

did you connect your device?

To accomplish this, you need to use a USB cable and enable debugging on your device. Follow instruction HERE for enabling USB debug.


I have always used the USB cable since I created my first application about two or three years ago.
I don't use the companion because it wastes a lot of time, the phone with the USB cable is faster.

However, I performed a factory reset on the phone, but it still doesn't work, while on other phones it works.

I also send the page that appears sometimes when I try to create the .apk. This time too, as soon as I tried to download the apk, it gave me an error, as you can see from the images. I tried again and the second time it created the apk, which however left me from that error I explained.

What I don't understand is that ten minutes before the page fault everything worked normally and has always worked, why now on Android 6 it works and on Android 10 it no longer works? This is what is incomprehensible.
Maybe the page error has nothing to do with it, because otherwise it wouldn't even work on Android 6.
As I wrote, I reset the phone, so it's not the phone.
As I said, I'll try to go over the changes I've made step by step, maybe I'll discover something.
Thanks anyway for your kindness and patience.
See you later.

Yes exactly, your http error 500 and your error report therefore not really helps. .


Can we see your Project file (.aia) Angelo?

It was to find out if it was a problem at your end with your device, or with your own app. I tried to copy what it was you were doing, playing a sound and vibrating when switching from one arrangement to another. This works OK for me on Android 13 companion.

From what you say, it appears that you have device issues....