Bluetooth list of paired devices not visible

The app compiled now does not show anymore the list of Bluetooth paired devices, whereas the app compiled some month ago from the same project as usually show the list of paired devices from which to select a device for connection (same smartphone). The list filled with BluetoothClient1>>AddressesAndNames is shown empty when starting the app and try to connect,

You have to ask for permission...


Thanks for your suggestion, but the problem remains, I start Bluetooth and pair the device to connect to before running the app, but the app no longer shows the paired devices, even though the same project (.aia) compiled a few months ago (.apk) shows them as usual on the same android phone with same android version.
All permissions have been given on both my app and bluetooth
I attach the pictures of the old project

and of the new one with your suggestions.

Thank you for your support

Turn on GPS location on your phone. If your phone is older than Android 12 (which you don't tell us) then the permissions you are asking about are not needed. But the GPS on the phone must be turned on.

This happens, because Google added more restrictions for bluetooth since SDK31, see also


Solved! The suggestion of Patryk_F, which has been taken from Anke, was of great help for me with the same problem, but it is still not working, bacause the first permission cannot be asked when initializing Screen1, but when clicking a button, and permission cannot be expressed with a text string, but from Screen1 menu. After hours of works, I finally found the solution in the image attached. The strange thing is that the app does not notify to ask permission from the user, but automatically gives permission to connect to Bluetooth.
My class was waiting for that ! I hope it will be useful also for you.

Some useful suggestions also here

The problem was the typo. You asked for Blutooth permissions instead of Bluetooth.

Yes, true, but only one time, I have tried with the right typo many times. In any case, there is now permission type in the Screen1 menu, but it is still not working, when permission is asked initializing Screen1, unless waiting some time, as suggested by Kevinkun.

Try this one:


My test APK should work on all Android versions without Location sensor enabled.
(Location enabled is needed for the BLE ext.)

Yes you are right. Now i checked in my app. It is possible that when I came to this conclusion I was testing an app with the ble extension.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.