Ant compiling gives error [BUILD FAILED]

As per this issue raised

I have the same problem but the solution that was given to that issue is not working for me

please help me what should I do !?...

you should try installing it directly:

I am using a mac, but thank you for your help I don't see your answer as any help to me.

Building for Mac is very similar to the Linux instructions, but see here:

[exec] Execute failed: Cannot run program "bundle" (in directory "/home/ec2-user/appinventor-sources/appinventor/docs/markdown"): error=2, No such file or directory

this error has been pops-up
I have tried on aws ec2

and now error change to
Compiling module Killed
on using ant command in appinventor folder

This type of error may be due to the insufficient memory or system resource constraint

Increase the available memory for the compilation process by setting the JAVA_OPTS environment variable to include the -Xmx option, which specifies the maximum heap size for the Java Virtual Machine (JVM). For example, you can set JAVA_OPTS to "-Xmx2g" to allocate 2 gigabytes of memory to the JVM:

export JAVA_OPTS="-Xmx2g"

try updading the JAVA_OTPS variable to increase the heap size of the JVM . May it will solve the issue.

1 Like

I solved my problem by shifting my macOS system to ubuntu 22+
and follow every step from the post suggested by @DHRUV_PATIDAR thanks, brother :sunglasses:.

and some of the steps follow from the Readme.MD to fix minor issues.

Thank you @TIMAI2 for your efforts to help me.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.