Ai2 app ssl connection in redis labs?

Some things are different from the manual, some things don't work, some aren't available, and so on.

for example, I can't install or use certbot

Are you running your own linux server ?

I set up a redis-server in a DO droplet that runs on Ubuntu 20.04 (LTS) x64

In which case you didn't follow the instructions that were provided....

I think I followed, but how to fix it? The claim is that E: Package 'python-certbot-apache' has no installation candidate

problems start at here:


See here for answer:

The reason for this is that the ppa is no longer required for 20.04 LTS (I have, and the howto works for an 18.04 LTS server). Looks like you can use the snap installation.

I will add a note in the howto. Thank you.

I couldn't do anything with the snap (an unknown concept for me) and gave the commands:
sudo apt-get install certbot python3-certbot-apache
sudo certbot certonly

At the place where the domain name had to be entered according to the instructions, I went, bought it and entered it, and after a few lines, the following message came: Problem binding to port 80: Could not bind to IPv4 or IPv6.
... what do I have to do?

You probably have apache up and running on port 80. If you read to the bottom of my guide, you will see you need to stop apache in order to run certbot.

sudo systemctl stop apache2

once finished start apache again

sudo systemctl start apache2

1 Like

I stopped apache and started certbot certonly and the result was:


Do as advised....


Yesterday I replaced the wrong ip in value of A with the correct one and tried today to stop apache again and start certbot ...
... results in:


Do I understand correctly that now cause may be in the firewall? How to stop it temporarily?

The onboard ubuntu firewall is ufw, but your droplet may have a server level firewall as well (my VPS does), so you may need to check for both.

I stopped the firewall with the command sudo ufw disable, started certbot, it seems to have finished successfully ...
... then sudo ufw enable and sudo systemctl start apache2 ...
... is everything okay now?


Yay !!

Now you need to test the app :wink:

The app does not protest, but it does not work either. The app itself works, of course, but it doesn't work with the server and doesn't give any error messages ...
... how to find out what exactly he is doing and what he is not?

ping ok, redis status:



Did you combine the certificates and set them to the correct place for stunnel ?
Is stunnel running ?

Can you test redis with the redis-cli ? (on the server)

sudo cat /etc/letsencrypt/live/ /etc/letsencrypt/live/ > /etc/stunnel/private.pem
-bash: /etc/stunnel/private.pem: Permission denied

If you read my guide, it advises going to root to do this...

sudo su

then try the command

Type exit to leave the root user